Kawasaki KFX450 Forum - KFX450Central banner
1 - 5 of 5 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter · #1 ·
just got my kfx back from dealer..they had to replace fuel pump,it wouldnt run after half throttle but done good at idle to half throttle. now it wont run right at a low rpm...it wants to cut out and die...but running at a high rpm it will scream!! anybody got any clues???
 

·
Registered
Joined
·
19 Posts
QUOTE (kfx450rquad @ Oct 30 2008, 08:35 PM) index.php?act=findpost&pid=13529
just got my kfx back from dealer..they had to replace fuel pump,it wouldnt run after half throttle but done good at idle to half throttle. now it wont run right at a low rpm...it wants to cut out and die...but running at a high rpm it will scream!! anybody got any clues???

Did you try adjusting the idle speed? I noticed on mine that it does not like run well with a very low idle speed. The adjustment is on the throttle body on the left side of the bike under the gas tank.
KT
 

·
Registered
Joined
·
121 Posts
check your voltage on your tps...
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #4 ·
QUOTE (Kawi Fan @ Nov 5 2008, 12:59 PM) index.php?act=findpost&pid=13642
Did you try adjusting the idle speed? I noticed on mine that it does not like run well with a very low idle speed. The adjustment is on the throttle body on the left side of the bike under the gas tank.
KT

no ijust took it back it to the dealer..will let you know with the outcome. thanks
 
1 - 5 of 5 Posts
Top