Kawasaki KFX450 Forum - KFX450Central banner

1 - 12 of 12 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1
alba pipe alba chip uni air filter no air box lid bike looses power in all gears when u hit the throttle down what would b the cause of this........
 

·
Registered
Joined
·
637 Posts
Is the exhaust full or s/o? Not sure about the alba chip but sounds like you need to get either a pciii so you can change the air/fuel ratio..Without that adjustment the quad won't run properly
 

·
Registered
Joined
·
11 Posts
Discussion Starter #3
its a slip on but alba asked me what bike i had and what mods i had so they could set the one up i got.....
 

·
Registered
Joined
·
11 Posts
Discussion Starter #6
i put a new plug in it no luck still doing the same thing it was kinda like a coffee color...... i took it to the dealer saterday um just waiting on an answer from them... ill let you all know what the problem was 4 future referance...
 

·
Registered
Joined
·
11 Posts
Discussion Starter #7
well i got my bike back yesterday from the dealer they left it sit out side in the rain all week charged me 50 bucks 2 tell me the alba computer is bad.. man was i pi$$ed... well i got a pciii and it cleared everything up it runs fine now....
 

·
Registered
Joined
·
285 Posts
QUOTE (mrbkfx450 @ Jul 19 2008, 05:46 AM) index.php?act=findpost&pid=10421
well i got my bike back yesterday from the dealer they left it sit out side in the rain all week charged me 50 bucks 2 tell me the alba computer is bad.. man was i pi$$ed... well i got a pciii and it cleared everything up it runs fine now....
LESSON LEARNED: DONT WASTE YOUR MONEY ON ANYTHING OTHER THEN A POWERCOMMANDER......the others can not remove fuel from the fuel map, only add it
 

·
Registered
Joined
·
11 Posts
Discussion Starter #9
my kfx started loseing power again went from 36 horse all the way down to 18 on the dino comes to find out i had a bad fuel pump.. waiting on kawie to let me kno if they are going to warrenty it or what...
 

·
Registered
Joined
·
637 Posts
QUOTE (mrbkfx450 @ Aug 18 2008, 06:06 PM) index.php?act=findpost&pid=11196
my kfx started loseing power again went from 36 horse all the way down to 18 on the dino comes to find out i had a bad fuel pump.. waiting on kawie to let me kno if they are going to warrenty it or what...
Hopefully it is under warranty...A few others have had the fuel pump go and it was covered..The various electrical components on this quad make me nervous (because I don't know much about how to fix them) i have a 1 yr extended and will probably extend another year for this reason
 

·
Registered
Joined
·
11 Posts
Discussion Starter #11
the fuel pump was covered thank god... there around 200 bucks ran it on the dino with a new map and the power commnder and new fuel pump its pulling 46 horse now... i think um gonna stick with that...
 

·
Registered
Joined
·
285 Posts
QUOTE (mrbkfx450 @ Aug 20 2008, 01:23 PM) index.php?act=findpost&pid=11231
the fuel pump was covered thank god... there around 200 bucks ran it on the dino with a new map and the power commnder and new fuel pump its pulling 46 horse now... i think um gonna stick with that...
good to hear u got it figured out....
 
1 - 12 of 12 Posts
Top