Kawasaki KFX450 Forum - KFX450Central banner

1 - 7 of 7 Posts

·
Registered
Joined
·
165 Posts
Discussion Starter #1
Here is a solution to replacing the stock relays. IMO these relays were a horrible choice for this application because the resistors (on the inside are subject to detaching) and they “ARE NOT WATER PROOF” what in the world were the engineers thinking? Any way the photos should be self explanatory but feel free to ask any questions.

RJ







 

·
Registered
Joined
·
637 Posts
Great info and pictorial..I don't have to worry about water proof issue being in the middle of the desert but its one of those things worth replacing..better safe than sorry.
 

·
Registered
Joined
·
165 Posts
Discussion Starter #3
QUOTE (offroadhunter @ Jun 7 2008, 03:20 PM) index.php?act=findpost&pid=9677
Great info and pictorial..I don't have to worry about water proof issue being in the middle of the desert but its one of those things worth replacing..better safe than sorry.
Sounds nice to ride in the desert... some day I'll get out west and try that out. Your only concern may be the resistors on the inside are subject to detaching or if you get carried away with the pressure washer. This has happen to me twice under race conditions... and it really sux.

RJ
 

·
Registered
Joined
·
3 Posts
hey would this be the problem with my quad il take it out riding an come back in a couple days an the relay is clicking under the hood top left one an the fuse is good it wont start just click an the odd time when it does this it will slowly turn over then just click my dealer can not fix this problem an im getting very pissed any info on this would be greatfull seeing how im considering switching brands after 4-5 months of owning this peice of crap an im on my second wire harnness 3rd or 4th battarie main fuse an now its been down there for a week an there putting a key switch in it this time
 

·
Registered
Joined
·
141 Posts
hey would this be the problem with my quad il take it out riding an come back in a couple days an the relay is clicking under the hood top left one an the fuse is good it wont start just click an the odd time when it does this it will slowly turn over then just click my dealer can not fix this problem an im getting very pissed any info on this would be greatfull seeing how im considering switching brands after 4-5 months of owning this peice of crap an im on my second wire harnness 3rd or 4th battarie main fuse an now its been down there for a week an there putting a key switch in it this time
Sounds like you are suffering the simple battery drain issue many of us have.
Next time it does it, check the battery voltage.

Normally, the battery should stay near 13v.

But if you are having such problems it is not likely to, and it will not stop until the ECU is replaced. Kawasaki refuses to authorize warranty coverage on the part though. (I think they fear a recall). So if this IS the case, you will need to do what I did and replace your stock ECU with Procom's fully reprogrammable ECU.

I have not had a problem since.
 
1 - 7 of 7 Posts
Top